summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorManuel Novoa III2003-09-03 09:18:18 +0200
committerManuel Novoa III2003-09-03 09:18:18 +0200
commit0e956fc164b97347279045e60033e6f2f176df3b (patch)
treebe9515a9bae85c641ce8c8756d378eb367614c4c /Makefile
parentFixup binutils cross builds (diff)
downloadbuildroot-0e956fc164b97347279045e60033e6f2f176df3b.tar.gz
buildroot-0e956fc164b97347279045e60033e6f2f176df3b.tar.xz
buildroot-0e956fc164b97347279045e60033e6f2f176df3b.zip
Add support for enabling use of libintl.
Add support for libstd++ in full locale mode, and remove the need for config hacks when using uClibc stub locale support. TODO -- gdb intl support is still broken. uClibc should auto-download the pregenerated locale data
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 87dc0af62..521debf4f 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,7 @@
TARGETS=
+DISABLE_NLS=
#############################################################
#
# EDIT this stuff to suit your system and preferences
@@ -69,6 +70,9 @@ OPTIMIZE_FOR_CPU=$(ARCH)
EXTRA_GCC_CONFIG_OPTIONS=
#EXTRA_GCC_CONFIG_OPTIONS=--without-float
+# Uncomment the following if you don't want gettext support.
+DISABLE_NLS:=--disable-nls
+
#############################################################
#
# The list of stuff to build for the target filesystem