summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2011-02-01 08:41:01 +0100
committerPeter Korsgaard2011-02-01 08:41:01 +0100
commit15f5bef0532aebe2f955cc9b377bd81f8dc06c4d (patch)
tree657d3038828acac67a3e23b723b6efecfb654853 /Makefile
parentCHANGES: #1681, #2839 and #2893 are resolved (diff)
downloadbuildroot-15f5bef0532aebe2f955cc9b377bd81f8dc06c4d.tar.gz
buildroot-15f5bef0532aebe2f955cc9b377bd81f8dc06c4d.tar.xz
buildroot-15f5bef0532aebe2f955cc9b377bd81f8dc06c4d.zip
make help: document ncurses, make V=1 and make O=<dir>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 04783f2ef..3ecc597b5 100644
--- a/Makefile
+++ b/Makefile
@@ -655,6 +655,7 @@ help:
@echo
@echo 'Configuration:'
@echo ' menuconfig - interactive curses-based configurator'
+ @echo ' nconfig - interactive ncurses-based configurator'
@echo ' xconfig - interactive Qt-based configurator'
@echo ' gconfig - interactive GTK-based configurator'
@echo ' oldconfig - resolve any unresolved symbols in .config'
@@ -673,6 +674,9 @@ help:
@echo ' source-check - check all packages for valid download URLs'
@echo ' external-deps - list external packages used'
@echo
+ @echo ' make V=0|1 - 0 => quiet build (default), 1 => verbose build'
+ @echo ' make O=dir - Locate all output files in "dir", including .config'
+ @echo
@$(foreach b, $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig)), \
printf " %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
@echo