summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorManuel Novoa III2003-11-21 03:28:21 +0100
committerManuel Novoa III2003-11-21 03:28:21 +0100
commit2192a03c9166daf7fb1648a03846c62b36184275 (patch)
tree1361d987a9335f1c3d143dd115dbfdfbe0de7ecf /Makefile
parentMake sure the necessary directories exist. (diff)
downloadbuildroot-2192a03c9166daf7fb1648a03846c62b36184275.tar.gz
buildroot-2192a03c9166daf7fb1648a03846c62b36184275.tar.xz
buildroot-2192a03c9166daf7fb1648a03846c62b36184275.zip
Fix some soft float make variables.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index a4cda2b0f..19bb5eb91 100644
--- a/Makefile
+++ b/Makefile
@@ -199,15 +199,13 @@ TARGETS+=ext2root
# what you are doing.
#
#############################################################
-ifeq ("$(strip $(TARGET_SOFT_FLOAT))","")
-ARCH_FPU_SUFFIX:=
-else
-ARCH_FPU_SUFFIX:=_nofpu
-endif
ifeq ($(SOFT_FLOAT),true)
SOFT_FLOAT_CONFIG_OPTION=--without-float
TARGET_SOFT_FLOAT=-msoft-float
+ARCH_FPU_SUFFIX:=_nofpu
+else
+ARCH_FPU_SUFFIX:=
endif
ifeq ($(ENABLE_LOCALE),true)