summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2010-06-21 22:13:20 +0200
committerPeter Korsgaard2010-06-21 22:16:34 +0200
commit2691d80803c96e32d923b0a20708b2dcb9aac20a (patch)
treef57c71c241667b04de52fd3cabf63d54f1b92439 /Makefile
parentcleanup/simplify kconfig changes for O= builds (diff)
downloadbuildroot-2691d80803c96e32d923b0a20708b2dcb9aac20a.tar.gz
buildroot-2691d80803c96e32d923b0a20708b2dcb9aac20a.tar.xz
buildroot-2691d80803c96e32d923b0a20708b2dcb9aac20a.zip
Makefile: fix make <blah>_defconfig
Make sure we only pass O=<path> if we were originally called like that, otherwise we might end up looking for the .config in the wrong place. Likewise, when changing between using O= or not (or simply running make <blah>_defconfig in a pristine source tree), we do end up having a .config, but no .config.cmd. It isn't really critical so just continue even if we couldn't read it. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ef78de120..c8f211b65 100644
--- a/Makefile
+++ b/Makefile
@@ -287,7 +287,7 @@ include package/Makefile.in
all: world
# In this section, we need .config
-include $(CONFIG_DIR)/.config.cmd
+-include $(CONFIG_DIR)/.config.cmd
# We also need the various per-package makefiles, which also add
# each selected package to TARGETS if that package was selected
@@ -587,7 +587,11 @@ flush:
%_defconfig: $(TOPDIR)/configs/%_defconfig
cp $^ $(CONFIG_DIR)/.config
+ifeq ($(O),output)
+ @$(MAKE) oldconfig
+else
@$(MAKE) O=$(O) oldconfig
+endif
configured: dirs host-sed kernel-headers uclibc-config busybox-config linux26-config