summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDmytro Milinevskyy2010-06-16 22:25:56 +0200
committerPeter Korsgaard2010-07-18 23:15:55 +0200
commit2b3a43f4e336d1af90200f5f34b931d09119e1e5 (patch)
treede35152b2462d6709019d60e47bd8d74f369e45c /Makefile
parentmove default skeleton to fs/ and drop busybox skeleton (diff)
downloadbuildroot-2b3a43f4e336d1af90200f5f34b931d09119e1e5.tar.gz
buildroot-2b3a43f4e336d1af90200f5f34b931d09119e1e5.tar.xz
buildroot-2b3a43f4e336d1af90200f5f34b931d09119e1e5.zip
fs: add option to define path to custom rootfs skeleton
Signed-off-by: Dmytro Milinevskyy <milinevskyy@gmail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 59151cc2f..744cae445 100644
--- a/Makefile
+++ b/Makefile
@@ -367,6 +367,10 @@ $(STAGING_DIR):
@mkdir -p $(STAGING_DIR)/usr/include
@mkdir -p $(STAGING_DIR)/usr/bin
+ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
+TARGET_SKELETON=$(BR2_ROOTFS_SKELETON_CUSTOM_PATH)
+endif
+
$(BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
if ! [ -d "$(TARGET_DIR)/bin" ]; then \