summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2007-06-19 17:19:27 +0200
committerPeter Korsgaard2007-06-19 17:19:27 +0200
commit2c649045197156221cc1d3d6328abb1c405db700 (patch)
tree67c5c0508a08ca587284d44f8578652d3902941d /Makefile
parentIf external toolchain support NPTL, then we should build Open POSIX Testsuite... (diff)
downloadbuildroot-2c649045197156221cc1d3d6328abb1c405db700.tar.gz
buildroot-2c649045197156221cc1d3d6328abb1c405db700.tar.xz
buildroot-2c649045197156221cc1d3d6328abb1c405db700.zip
Hide troublesome environment variables from sub processes
(E.G. screws up gdb, busybox, ..)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e3c18caca..63535e182 100644
--- a/Makefile
+++ b/Makefile
@@ -46,6 +46,13 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
cc-option = $(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /dev/null \
> /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ;)
+#############################################################
+#
+# Hide troublesome environment variables from sub processes
+#
+#############################################################
+unexport CROSS_COMPILE
+unexport ARCH
#############################################################
#