summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-06-02 00:16:28 +0200
committerBernhard Reutner-Fischer2007-06-02 00:16:28 +0200
commit3096f34d27f32fc179ca051ad78ac9ee2165c72e (patch)
tree4e8bf2d890181cc77f0fd74e339d6db6721c2331 /Makefile
parentCleanup, get rid of MPG123_WORKDIR, use $@, libmad not needed (diff)
downloadbuildroot-3096f34d27f32fc179ca051ad78ac9ee2165c72e.tar.gz
buildroot-3096f34d27f32fc179ca051ad78ac9ee2165c72e.tar.xz
buildroot-3096f34d27f32fc179ca051ad78ac9ee2165c72e.zip
- add BR2_PREFER_STATIC_LIB config option to be able to select if we prefer to build static or dynamic libs/bins.
- depending on the BR2_GNU_BUILD_SUFFIX, set the respective EXEEXT, LIBEXT, SHREXT extensions for use on the target. Thanks to Tom for suplying a diff which implements these.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 12851444f..86f8dce0f 100644
--- a/Makefile
+++ b/Makefile
@@ -66,7 +66,32 @@ include package/Makefile.in
#
#############################################################
+ifneq (,$(findstring linux,$(BR2_GNU_BUILD_SUFFIX)))
+EXEEXT:=
+LIBEXT:=.a
+SHREXT:=.so
+endif
+ifneq (,$(findstring apple,$(BR2_GNU_BUILD_SUFFIX)))
+EXEEXT:=.pear
+LIBEXT:=.dunno
+SHREXT:=.dylib
+endif
+ifneq (,$(findstring cygwin,$(BR2_GNU_BUILD_SUFFIX)))
+EXEEXT:=.exe
+LIBEXT:=.lib
+SHREXT:=.dll
+endif
+ifneq (,$(findstring mingw,$(BR2_GNU_BUILD_SUFFIX)))
+EXEEXT:=.exe
+LIBEXT:=.lib
+SHREXT:=.dll
+endif
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+LIBTGTEXT=$(LIBEXT)
+else
+LIBTGTEXT=$(SHREXT)
+endif
all: world