summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorHamish Moffatt2008-09-11 04:22:47 +0200
committerHamish Moffatt2008-09-11 04:22:47 +0200
commit346844d05781d9dfaaae8d110b58242f1755c764 (patch)
tree36a42480ca4ef471fbf18da485ecee66c05f4f6b /Makefile
parentMove project-specific stamp files into a project-specific directory (diff)
downloadbuildroot-346844d05781d9dfaaae8d110b58242f1755c764.tar.gz
buildroot-346844d05781d9dfaaae8d110b58242f1755c764.tar.xz
buildroot-346844d05781d9dfaaae8d110b58242f1755c764.zip
Applied patch from Brian Foster <brian.foster@innova-card.com>:
make "make clean" remove the .root stamp, so that everything will be reinstalled properly on a subsequent build. (bug id 4304) Also remove new autotools-stamps directory.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1f9e7f6fe..d44630215 100644
--- a/Makefile
+++ b/Makefile
@@ -358,10 +358,10 @@ external-deps:
#
#############################################################
clean: $(TARGETS_CLEAN)
- rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE)
+ rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(PROJECT_BUILD_DIR)/.root $(PROJECT_BUILD_DIR)/autotools-stamps
dirclean: $(TARGETS_DIRCLEAN)
- rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE)
+ rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(PROJECT_BUILD_DIR)/.root $(PROJECT_BUILD_DIR)/autotools-stamps
distclean:
ifeq ($(DL_DIR),$(BASE_DIR)/dl)