summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2010-06-05 20:54:43 +0200
committerPeter Korsgaard2010-06-05 21:14:59 +0200
commit35fac17ebca566795bdd947033eedb5c5ea3a492 (patch)
tree3c31cf072cfd30e8707ad389a48f25e880a576ed /Makefile
parentkconfig: fix qconf (make xconfig) linking (diff)
downloadbuildroot-35fac17ebca566795bdd947033eedb5c5ea3a492.tar.gz
buildroot-35fac17ebca566795bdd947033eedb5c5ea3a492.tar.xz
buildroot-35fac17ebca566795bdd947033eedb5c5ea3a492.zip
Makefile: cleanup *conf targets
The make targets for the kconfig conf/mconf/qconf are almost identical, so us a single rule for it. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile22
1 files changed, 4 insertions, 18 deletions
diff --git a/Makefile b/Makefile
index e36b47541..a75ca3e5f 100644
--- a/Makefile
+++ b/Makefile
@@ -469,23 +469,9 @@ all: menuconfig
HOSTCFLAGS=$(CFLAGS_FOR_BUILD)
export HOSTCFLAGS
-$(CONFIG)/conf:
- @mkdir -p $(CONFIG)/buildroot-config
- $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) conf
- -@if [ ! -f .config ]; then \
- cp $(CONFIG_DEFCONFIG) .config; \
- fi
-
-$(CONFIG)/mconf:
- @mkdir -p $(CONFIG)/buildroot-config
- $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) mconf
- -@if [ ! -f .config ]; then \
- cp $(CONFIG_DEFCONFIG) .config; \
- fi
-
-$(CONFIG)/qconf:
- @mkdir -p $(CONFIG)/buildroot-config
- $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) qconf
+$(CONFIG)/%onf:
+ mkdir -p $(CONFIG)/buildroot-config
+ $(MAKE) CC="$(HOSTCC)" -C $(CONFIG) $(notdir $@)
-@if [ ! -f .config ]; then \
cp $(CONFIG_DEFCONFIG) .config; \
fi
@@ -513,7 +499,7 @@ config: $(CONFIG)/conf
$(CONFIG)/conf $(CONFIG_CONFIG_IN)
oldconfig: $(CONFIG)/conf
- @mkdir -p $(CONFIG)/buildroot-config
+ mkdir -p $(CONFIG)/buildroot-config
@KCONFIG_AUTOCONFIG=$(CONFIG)/buildroot-config/auto.conf \
KCONFIG_AUTOHEADER=$(CONFIG)/buildroot-config/autoconf.h \
$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)