summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen2003-03-04 08:56:11 +0100
committerEric Andersen2003-03-04 08:56:11 +0100
commit36830baea210bba2490f643a1d147bf9adb2b62b (patch)
tree1dc577ad3a2451f87cc63c0d206d658511f9246b /Makefile
parentChange a few defaults (diff)
downloadbuildroot-36830baea210bba2490f643a1d147bf9adb2b62b.tar.gz
buildroot-36830baea210bba2490f643a1d147bf9adb2b62b.tar.xz
buildroot-36830baea210bba2490f643a1d147bf9adb2b62b.zip
Add in a GNU_HOST_NAME
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 9f0f84d81..ae8561ec7 100644
--- a/Makefile
+++ b/Makefile
@@ -155,6 +155,18 @@ STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
IMAGE:=$(BASE_DIR)/root_fs
GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux
KERNEL_CROSS=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
+HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
+ -e 's/sparc.*/sparc/' \
+ -e 's/arm.*/arm/g' \
+ -e 's/m68k.*/m68k/' \
+ -e 's/ppc/powerpc/g' \
+ -e 's/v850.*/v850/g' \
+ -e 's/sh[234]/sh/' \
+ -e 's/mips-.*/mips/' \
+ -e 's/mipsel-.*/mipsel/' \
+ -e 's/cris.*/cris/' \
+ )
+GNU_HOST_NAME:=$(HOST_ARCH)-pc-linux-gnu
all: world