summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-09-18 15:12:25 +0200
committerBernhard Reutner-Fischer2007-09-18 15:12:25 +0200
commit3b08e64d6f6dc3f4eba3b84e1503839b22e6dc15 (patch)
treec622e89aca01433f42eb095cf4076f5f7c04d600 /Makefile
parent- bump version to 2.4.9 (diff)
downloadbuildroot-3b08e64d6f6dc3f4eba3b84e1503839b22e6dc15.tar.gz
buildroot-3b08e64d6f6dc3f4eba3b84e1503839b22e6dc15.tar.xz
buildroot-3b08e64d6f6dc3f4eba3b84e1503839b22e6dc15.zip
- forgot to put base-target's sources into the source target.
Thanks to Ulf for pointing out this error of mine..
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index e029cfd68..717bb7b64 100644
--- a/Makefile
+++ b/Makefile
@@ -216,8 +216,7 @@ include target/Makefile.in
TARGETS+=erase-fakeroots
TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
-TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
-BASE_TARGETS_SOURCE:=$(patsubst %,%-source,$(BASE_TARGETS))
+TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS) $(BASE_TARGETS))
TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
TARGETS_ALL:=$(patsubst %,__real_tgt_%,$(TARGETS))
# all targets depend on the crosscompiler and it's prerequisites
@@ -284,7 +283,7 @@ $(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root
erase-fakeroots:
rm -f $(PROJECT_BUILD_DIR)/.fakeroot*
-source: $(BASE_TARGETS_SOURCE) $(TARGETS_SOURCE) $(HOST_SOURCE)
+source: $(TARGETS_SOURCE) $(HOST_SOURCE)
_source-check:
$(MAKE) SPIDER=--spider source