summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen2007-01-10 07:55:27 +0100
committerEric Andersen2007-01-10 07:55:27 +0100
commit3da708e479442124aceae2f48dbdc8375ac4e9a2 (patch)
treef53015cba2650dd4bc4b38ddf875babf05342c64 /Makefile
parentadd in glib2 (diff)
downloadbuildroot-3da708e479442124aceae2f48dbdc8375ac4e9a2.tar.gz
buildroot-3da708e479442124aceae2f48dbdc8375ac4e9a2.tar.xz
buildroot-3da708e479442124aceae2f48dbdc8375ac4e9a2.zip
link $(STAGING_DIR)/usr/lib to $(STAGING_DIR)/lib
to make glib2 (and packages with similar confusion) work properly, while still being able to cross compile
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 6782a8228..78f2f0071 100644
--- a/Makefile
+++ b/Makefile
@@ -101,7 +101,9 @@ $(TOOL_BUILD_DIR):
$(STAGING_DIR):
@mkdir -p $(STAGING_DIR)/lib
@mkdir -p $(STAGING_DIR)/include
+ @mkdir -p $(STAGING_DIR)/usr
@mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
+ @ln -snf ../lib $(STAGING_DIR)/usr/lib
@ln -snf ../lib $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib
$(TARGET_DIR):