summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMichael Roth2009-09-23 01:30:12 +0200
committerPeter Korsgaard2009-09-23 09:15:39 +0200
commit416323e93442646e344a4e914776520c5e552fa0 (patch)
tree3b9ea23227dcffb5cb37a1541431b74b139f536e /Makefile
parentrename TOOL_BUILD_DIR to TOOLCHAIN_DIR (diff)
downloadbuildroot-416323e93442646e344a4e914776520c5e552fa0.tar.gz
buildroot-416323e93442646e344a4e914776520c5e552fa0.tar.xz
buildroot-416323e93442646e344a4e914776520c5e552fa0.zip
Move download directory 'dl' back to the top hierachy of buildroot
Signed-off-by: Michael Roth <mroth@nessie.de> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index a8a585879..176992c49 100644
--- a/Makefile
+++ b/Makefile
@@ -232,7 +232,7 @@ $(if $(BASE_DIR),, $(error output directory "$(O)" does not exist))
DL_DIR=$(call qstrip,$(BR2_DL_DIR))
ifeq ($(DL_DIR),)
-DL_DIR:=$(BASE_DIR)/dl
+DL_DIR:=$(TOPDIR)/dl
endif
BUILD_DIR:=$(BASE_DIR)/build
@@ -443,7 +443,7 @@ dirclean: $(TARGETS_DIRCLEAN)
rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE) $(BUILD_DIR)/.root $(STAMP_DIR)
distclean:
-ifeq ($(DL_DIR),$(BASE_DIR)/dl)
+ifeq ($(DL_DIR),$(TOPDIR)/dl)
rm -rf $(DL_DIR)
endif
rm -rf $(TOOLCHAIN_DIR) $(BUILD_DIR) $(BINARIES_DIR) \