summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2010-04-03 18:46:46 +0200
committerThomas Petazzoni2010-06-22 21:20:25 +0200
commit487e21cff69b30b404146b2ffb46959a728a4002 (patch)
tree9d809fbe41eb64bf9f389216168526149827be68 /Makefile
parentdocs: Document location of .config for out-of-tree builds (diff)
downloadbuildroot-487e21cff69b30b404146b2ffb46959a728a4002.tar.gz
buildroot-487e21cff69b30b404146b2ffb46959a728a4002.tar.xz
buildroot-487e21cff69b30b404146b2ffb46959a728a4002.zip
New, simpler, infrastructure for building the Linux kernel
This patch introduces a single, simple, infrastructure to build the Linux kernel. The configuration is limited to : * Kernel version: a fixed recent stable version, same as kernel headers version (for internal toolchains only), custom stable version, or custom tarball URL * Kernel patch: either a local file, directory or an URL * Kernel configuration: either the name of a defconfig or the location of a custom configuration file * Kernel image: either uImage, bzImage, zImage or vmlinux. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 7e00b657e..3bf23d9c4 100644
--- a/Makefile
+++ b/Makefile
@@ -323,6 +323,7 @@ endif
include boot/common.mk
include target/Makefile.in
+include linux/linux.mk
include fs/common.mk
TARGETS+=erase-fakeroots