summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-09-26 23:12:38 +0200
committerBernhard Reutner-Fischer2007-09-26 23:12:38 +0200
commit4b0d5a80f8b38bf9a264584ffc90b901f82c8cbb (patch)
tree56762054e7ac277378262dd98c4ff8c9c55a7d1e /Makefile
parent- sjhill? (diff)
downloadbuildroot-4b0d5a80f8b38bf9a264584ffc90b901f82c8cbb.tar.gz
buildroot-4b0d5a80f8b38bf9a264584ffc90b901f82c8cbb.tar.xz
buildroot-4b0d5a80f8b38bf9a264584ffc90b901f82c8cbb.zip
- revert some bad checkins, fixup bad settings in atmel targets and move the gcc target abi back to a place where the other arch-specific settings live
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 19ba26b5d..a7d7f04d2 100644
--- a/Makefile
+++ b/Makefile
@@ -168,7 +168,7 @@ PREFERRED_LIB_FLAGS:=--enable-static --enable-shared
# along with the packages to build for the target.
#
##############################################################
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
BASE_TARGETS:=uclibc-configured binutils cross_compiler uclibc-target-utils
else
BASE_TARGETS:=uclibc
@@ -200,7 +200,7 @@ include project/*.mk
# We also need the various per-package makefiles, which also add
# each selected package to TARGETS if that package was selected
# in the .config file.
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
# avoid pulling in external toolchain which is broken for toplvl parallel builds
include $(filter-out $(wildcard toolchain/external-toolchain/*),$(wildcard toolchain/*/*.mk))
else