summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2011-04-25 00:10:45 +0200
committerPeter Korsgaard2011-04-25 00:10:45 +0200
commit4bb33dce49245ed36137c7028a9d170d8f4fe8ff (patch)
tree61b0da2ae98bfcb3d5163771373499478cf48d37 /Makefile
parentMakefile: remove outdated make targets (diff)
downloadbuildroot-4bb33dce49245ed36137c7028a9d170d8f4fe8ff.tar.gz
buildroot-4bb33dce49245ed36137c7028a9d170d8f4fe8ff.tar.xz
buildroot-4bb33dce49245ed36137c7028a9d170d8f4fe8ff.zip
Makefile: make help: show busybox/ctng/linux/uclibc-menuconfig if enabled
For this we need to read .config. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 98cc09f93..d4f5e1513 100644
--- a/Makefile
+++ b/Makefile
@@ -42,7 +42,7 @@ export BR2_VERSION_FULL:=$(BR2_VERSION)$(shell $(TOPDIR)/scripts/setlocalversion
noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
defconfig %_defconfig savedefconfig allyesconfig allnoconfig silentoldconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
- source-check help
+ source-check
# Strip quotes and then whitespaces
qstrip=$(strip $(subst ",,$(1)))
@@ -661,6 +661,18 @@ help:
@echo ' randpackageconfig - New config with random answer to package options'
@echo ' allyespackageconfig - New config where pkg options are accepted with yes'
@echo ' allnopackageconfig - New config where package options are answered with no'
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+ @echo ' busybox-menuconfig - Run BusyBox menuconfig'
+endif
+ifeq ($(BR2_LINUX_KERNEL),y)
+ @echo ' linux-menuconfig - Run Linux kernel menuconfig'
+endif
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+ @echo ' uclibc-menuconfig - Run uClibc menuconfig'
+endif
+ifeq ($(BR2_TOOLCHAIN_CTNG),y)
+ @echo ' ctng-menuconfig - Run crosstool-NG menuconfig'
+endif
@echo
@echo 'Miscellaneous:'
@echo ' source - download all sources needed for offline-build'