summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas De Schampheleire2011-07-27 11:34:51 +0200
committerPeter Korsgaard2011-08-04 21:44:56 +0200
commit4eb982cf90f16927442f4e7692ce51dd5d21f37b (patch)
treeab836ecca9dd7b7cd53e9c2aacb2a93a68e3da17 /Makefile
parentiw: bump to version 3.0 (diff)
downloadbuildroot-4eb982cf90f16927442f4e7692ce51dd5d21f37b.tar.gz
buildroot-4eb982cf90f16927442f4e7692ce51dd5d21f37b.tar.xz
buildroot-4eb982cf90f16927442f4e7692ce51dd5d21f37b.zip
'source' target should depend on 'dirs'
In the following command flow: make distclean make <board>_defconfig make source the dl directory would normally be created by the first wget download. If there are no such downloads, e.g. because you use a local download mirror (e.g. scp, file) or only use git/svn/hg/bzr repositories, the dl directory is not created automatically. This causes e.g. the 'pushd' command in the respective _DOWNLOAD commands to fail. This patch adds a dependency to the 'dirs' target to 'source', fixing this scenario. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 02a165999..df6ce8f53 100644
--- a/Makefile
+++ b/Makefile
@@ -486,7 +486,7 @@ target-purgelocales:
done
endif
-source: $(TARGETS_SOURCE) $(HOST_SOURCE)
+source: dirs $(TARGETS_SOURCE) $(HOST_SOURCE)
external-deps:
@$(MAKE) -Bs DL_MODE=SHOW_EXTERNAL_DEPS $(EXTRAMAKEARGS) source | sort -u