summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2009-07-30 17:26:49 +0200
committerThomas Petazzoni2009-09-05 14:43:16 +0200
commit580c6d9b448ea8db5c9fe8f99aa43967d297903b (patch)
tree23ea2f53cae3b47468ef8fc4179303da7162739d /Makefile
parentuClibc as of 20090825 requires the ARCH to be specified when we call it's make (diff)
downloadbuildroot-580c6d9b448ea8db5c9fe8f99aa43967d297903b.tar.gz
buildroot-580c6d9b448ea8db5c9fe8f99aa43967d297903b.tar.xz
buildroot-580c6d9b448ea8db5c9fe8f99aa43967d297903b.zip
makefile: new qstrip make function
Define a qstrip function that strips double quotes and then whitespaces around a given string. This is a very commonly needed thing, and having a function allows to remove a large quantity of hand-written definitions, followed by a dummy comment to make text editors not crazy because of the unmatching double quote. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 568348494..fd272b5f2 100644
--- a/Makefile
+++ b/Makefile
@@ -40,6 +40,10 @@ else
BR2_LOCAL:=$(TOPDIR)/local
endif
+# Strip quotes and then whitespaces
+qstrip=$(strip $(subst ",,$(1)))
+#"))
+
# Variables for use in Make constructs
comma:=,
empty:=