summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2009-10-04 22:09:25 +0200
committerPeter Korsgaard2009-10-04 22:20:28 +0200
commit58fd779a4355e5bfa2bc0b15ed9c4664f44c7a0f (patch)
tree7ea64355eb10d13aa8f1d6e17688530a6d344d52 /Makefile
parentMakefile: add rand/allyes/allno package config targets (diff)
downloadbuildroot-58fd779a4355e5bfa2bc0b15ed9c4664f44c7a0f.tar.gz
buildroot-58fd779a4355e5bfa2bc0b15ed9c4664f44c7a0f.tar.xz
buildroot-58fd779a4355e5bfa2bc0b15ed9c4664f44c7a0f.zip
buildroot; move defconfigs to configs/ and print in help
As discussed earlier on the mailing list. It simplifies code, gives more sensible error message on typos and makes the defconfigs easier to find for users. Furthermore, update documentation to match. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 5497c9b45..bbd49d415 100644
--- a/Makefile
+++ b/Makefile
@@ -591,9 +591,9 @@ endif # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
flush:
rm -f $(BUILD_DIR)/tgt-config.cache
-%_defconfig: $(CONFIG)/conf
- cp $(shell find ./target/ -name $@) .config
- -@$(MAKE) oldconfig
+%_defconfig: $(TOPDIR)/configs/%_defconfig
+ cp $^ .config
+ @$(MAKE) oldconfig
configured: dirs host-sed kernel-headers uclibc-config busybox-config linux26-config
@@ -628,6 +628,9 @@ help:
@echo ' external-deps - list external packages used'
@echo ' flush - flush configuration cache'
@echo
+ @$(foreach b, $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig)), \
+ printf " %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
+ @echo
@echo 'See docs/README and docs/buildroot.html for further details'
@echo