summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorGustavo Zacarias2010-12-31 12:39:05 +0100
committerPeter Korsgaard2011-01-02 22:55:36 +0100
commit5ad139ebc9916413d25cfe1603da9aef89752231 (patch)
treee6f690bff5d91da2b768c7397d4b70e0adbc619b /Makefile
parentoprofile: use new libbfd option (diff)
downloadbuildroot-5ad139ebc9916413d25cfe1603da9aef89752231.tar.gz
buildroot-5ad139ebc9916413d25cfe1603da9aef89752231.tar.xz
buildroot-5ad139ebc9916413d25cfe1603da9aef89752231.zip
toolchain: do staging symlink
Make an output/staging -> sysroot symlink just for compatibility purposes. This may be gone in the future so don't count on it, use $(STAGING_DIR) instead. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e634848fa..7e08cf3cc 100644
--- a/Makefile
+++ b/Makefile
@@ -394,6 +394,7 @@ $(STAGING_DIR):
@mkdir -p $(STAGING_DIR)/usr/lib
@mkdir -p $(STAGING_DIR)/usr/include
@mkdir -p $(STAGING_DIR)/usr/bin
+ @ln -snf $(STAGING_DIR) $(BASE_DIR)/staging
ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
TARGET_SKELETON=$(BR2_ROOTFS_SKELETON_CUSTOM_PATH)
@@ -605,7 +606,8 @@ endif
clean:
rm -rf $(STAGING_DIR) $(TARGET_DIR) $(BINARIES_DIR) $(HOST_DIR) \
- $(STAMP_DIR) $(BUILD_DIR) $(TOOLCHAIN_DIR) $(TOOLCHAIN_EXTERNAL_DIR)
+ $(STAMP_DIR) $(BUILD_DIR) $(TOOLCHAIN_DIR) $(BASE_DIR)/staging \
+ $(TOOLCHAIN_EXTERNAL_DIR)
distclean: clean
ifeq ($(DL_DIR),$(TOPDIR)/dl)