summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Frysinger2005-09-09 04:49:10 +0200
committerMike Frysinger2005-09-09 04:49:10 +0200
commit5bc1f0c323a5795378a0b2fb7eef96df07cd24fd (patch)
treef959805f1da04e26dba045691f9ab5a768fcc027 /Makefile
parenttouchup target menu display (diff)
downloadbuildroot-5bc1f0c323a5795378a0b2fb7eef96df07cd24fd.tar.gz
buildroot-5bc1f0c323a5795378a0b2fb7eef96df07cd24fd.tar.xz
buildroot-5bc1f0c323a5795378a0b2fb7eef96df07cd24fd.zip
Allan Clark writes:
Quick patch to avoid deleting my directory of RPM Sources. I tend to use buildroot as "make DL_DIR=/.rh/SOURCES", with the rpm topdir set to $HOME/.rh in my .rpmmacros -- allows me to build RPMs as non-root, and share the source with buildroot. Problem is, buildroot likes to delete my directory :(
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index dd384e9e8..5d8f72599 100644
--- a/Makefile
+++ b/Makefile
@@ -133,7 +133,10 @@ dirclean: $(TARGETS_DIRCLEAN)
rm -rf $(STAGING_DIR) $(TARGET_DIR) $(IMAGE)
distclean:
- rm -rf $(DL_DIR) $(BUILD_DIR) $(LINUX_KERNEL) $(IMAGE)
+ifeq ($(DL_DIR),$(BASE_DIR)/dl)
+ rm -rf $(DL_DIR)
+endif
+ rm -rf $(BUILD_DIR) $(LINUX_KERNEL) $(IMAGE)
sourceball:
rm -rf $(BUILD_DIR)