summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Frysinger2010-11-28 22:10:13 +0100
committerPeter Korsgaard2010-11-28 22:13:05 +0100
commit66254843a57420cf46899b71526fe2481ca7a554 (patch)
treeb272268a36a185e1756d7e13eb886ff29b943b49 /Makefile
parentpackage/Makefile.in: Add OBJDUMP=$(TARGET_OBJDUMP) to TARGET_CONFIGURE_OPTS (diff)
downloadbuildroot-66254843a57420cf46899b71526fe2481ca7a554.tar.gz
buildroot-66254843a57420cf46899b71526fe2481ca7a554.tar.xz
buildroot-66254843a57420cf46899b71526fe2481ca7a554.zip
target-finalize: libtread_db: support nonstd toolchain setups
Certain toolchain configs (E.G. on blackfin), don't use symlinks, so the file name to match is the actual SONAME (.so.*). Support these toolchains as well. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index fc165e1b5..8dbb026b7 100644
--- a/Makefile
+++ b/Makefile
@@ -418,7 +418,7 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/share/gtk-doc
-rmdir $(TARGET_DIR)/usr/share 2>/dev/null
endif
- find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so' | \
+ find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so*' | \
xargs $(STRIPCMD) 2>/dev/null || true
find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
xargs -r $(STRIPCMD) $(STRIP_STRIP_UNNEEDED)