summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorJavier Viguera2010-11-26 19:26:56 +0100
committerPeter Korsgaard2010-11-27 21:41:20 +0100
commit69b2cc76b3587a3ed551e7d2e025fd3ea4f33992 (patch)
treea2f67e05defc1430fccdd2d68025343e8adf95c5 /Makefile
parentMerge branch 'for-2010.11/faq' of git://git.busybox.net/~tpetazzoni/git/build... (diff)
downloadbuildroot-69b2cc76b3587a3ed551e7d2e025fd3ea4f33992.tar.gz
buildroot-69b2cc76b3587a3ed551e7d2e025fd3ea4f33992.tar.xz
buildroot-69b2cc76b3587a3ed551e7d2e025fd3ea4f33992.zip
target-finalize: do not strip libthread_db
Fix previous commit not to strip libthread_db library. In the previous commit the wildcard was incorrectly matching the symbolic link instead of the real library file. Signed-off-by: Javier Viguera <javier.viguera@digi.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 6752aa65b..fc165e1b5 100644
--- a/Makefile
+++ b/Makefile
@@ -418,7 +418,7 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/share/gtk-doc
-rmdir $(TARGET_DIR)/usr/share 2>/dev/null
endif
- find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db.so*' | \
+ find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so' | \
xargs $(STRIPCMD) 2>/dev/null || true
find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
xargs -r $(STRIPCMD) $(STRIP_STRIP_UNNEEDED)