summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2010-08-11 20:01:23 +0200
committerThomas Petazzoni2010-09-01 12:26:29 +0200
commit6f38119cbb2cf5dd9c64109ff331a3d3868460ff (patch)
treee1647a3823aa22d25c526e5ce164debceb2cf37f /Makefile
parentRemove CONFIG_DEFCONFIG (diff)
downloadbuildroot-6f38119cbb2cf5dd9c64109ff331a3d3868460ff.tar.gz
buildroot-6f38119cbb2cf5dd9c64109ff331a3d3868460ff.tar.xz
buildroot-6f38119cbb2cf5dd9c64109ff331a3d3868460ff.zip
Implement %_defconfig similarly to the kernel
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index e3cebe2b6..2b5780dd1 100644
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,7 @@ CONFIG=package/config
DATE:=$(shell date +%Y%m%d)
noconfig_targets:=menuconfig gconfig xconfig config oldconfig randconfig \
- defconfig allyesconfig allnoconfig release \
+ defconfig %_defconfig allyesconfig allnoconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
source-check help
@@ -553,6 +553,12 @@ defconfig: $(BUILD_DIR)/buildroot-config/conf
KCONFIG_AUTOHEADER=$(BUILD_DIR)/buildroot-config/autoconf.h \
BUILDROOT_CONFIG=$(CONFIG_DIR)/.config $< -d $(CONFIG_CONFIG_IN)
+%_defconfig: $(BUILD_DIR)/buildroot-config/conf $(TOPDIR)/configs/%_defconfig
+ @mkdir -p $(BUILD_DIR)/buildroot-config
+ @KCONFIG_AUTOCONFIG=$(BUILD_DIR)/buildroot-config/auto.conf \
+ KCONFIG_AUTOHEADER=$(BUILD_DIR)/buildroot-config/autoconf.h \
+ BUILDROOT_CONFIG=$(CONFIG_DIR)/.config $< -D $(TOPDIR)/configs/$@ $(CONFIG_CONFIG_IN)
+
# check if download URLs are outdated
source-check: allyesconfig
$(MAKE) $(EXTRAMAKEARGS) _source-check
@@ -580,10 +586,6 @@ endif
flush:
rm -f $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
-%_defconfig: $(TOPDIR)/configs/%_defconfig
- cp $^ $(CONFIG_DIR)/.config
- @$(MAKE) $(EXTRAMAKEARGS) oldconfig
-
configured: dirs host-sed kernel-headers uclibc-config busybox-config linux26-config
prepatch: gcc-patched binutils-patched gdb-patched uclibc-patched