summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorUlf Samuelsson2007-09-12 06:34:16 +0200
committerUlf Samuelsson2007-09-12 06:34:16 +0200
commit7521f37372839210e18207223ef54ed768422726 (patch)
treeb83665b04f7a60ca456d331cfd19631147cc41b2 /Makefile
parentUnbreak multiple boards, add Ingo's rt patch (diff)
downloadbuildroot-7521f37372839210e18207223ef54ed768422726.tar.gz
buildroot-7521f37372839210e18207223ef54ed768422726.tar.xz
buildroot-7521f37372839210e18207223ef54ed768422726.zip
Add hooks for creating your own board support package
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index f37b9ede7..5414644d3 100644
--- a/Makefile
+++ b/Makefile
@@ -35,11 +35,20 @@ noconfig_targets:=menuconfig config oldconfig randconfig \
# Pull in the user's configuration file
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
+ifeq ($(BOARD),)
-include $(TOPDIR).config
+else
+-include $(TOPDIR)/local/$(BOARD)/$(BOARD).config
+endif
endif
ifneq ($(BUILDROOT_DL_DIR),)
BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
endif
+ifneq ($(BUILDROOT_LOCAL),)
+LOCAL:=$(BUILDROOT_LOCAL)
+else
+LOCAL:=local
+endif
# To put more focus on warnings, be less verbose as default
# Use 'make V=1' to see the full commands