summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorYann E. MORIN2011-07-14 13:02:33 +0200
committerPeter Korsgaard2011-07-15 20:57:59 +0200
commit7c2974596971e20a7d8d606d88bfd1b682472edb (patch)
tree2bab87ef7aeec9277154fd9dc080a3928ac528c3 /Makefile
parentpackage: add libyaml (diff)
downloadbuildroot-7c2974596971e20a7d8d606d88bfd1b682472edb.tar.gz
buildroot-7c2974596971e20a7d8d606d88bfd1b682472edb.tar.xz
buildroot-7c2974596971e20a7d8d606d88bfd1b682472edb.zip
Makefile: unbreak source-check
'source-check' breaks because the *_DEFCONFIG options are empty strings. There is an explicit check to avoid erroring-out when doing 'source', but not when doing 'source-check'. This patch set DL_MODE right from the first sub-make call. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 2f3802c10..ffe634391 100644
--- a/Makefile
+++ b/Makefile
@@ -488,9 +488,6 @@ endif
source: $(TARGETS_SOURCE) $(HOST_SOURCE)
-_source-check:
- $(MAKE) DL_MODE=SOURCE_CHECK $(EXTRAMAKEARGS) source
-
external-deps:
@$(MAKE) -Bs DL_MODE=SHOW_EXTERNAL_DEPS $(EXTRAMAKEARGS) source | sort -u
@@ -595,7 +592,7 @@ savedefconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
# check if download URLs are outdated
source-check: allyesconfig
- $(MAKE) $(EXTRAMAKEARGS) _source-check
+ $(MAKE) DL_MODE=SOURCE_CHECK $(EXTRAMAKEARGS) source
endif # ifeq ($(BR2_HAVE_DOT_CONFIG),y)