summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-06-07 14:57:03 +0200
committerBernhard Reutner-Fischer2007-06-07 14:57:03 +0200
commit825ff341daf4a4910544afc658a0ef0a3d91f71a (patch)
treefe01df609229411712880233f4506d07675617bc /Makefile
parent- update defconfig (diff)
downloadbuildroot-825ff341daf4a4910544afc658a0ef0a3d91f71a.tar.gz
buildroot-825ff341daf4a4910544afc658a0ef0a3d91f71a.tar.xz
buildroot-825ff341daf4a4910544afc658a0ef0a3d91f71a.zip
- provide a "source-check" target that tries to download all packages with
wget's spider-mode (i.e. just see if the server says the file is there without actually downloading the files. Convenient to check for unavailable source-packages.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index dff5fbf8e..e3c18caca 100644
--- a/Makefile
+++ b/Makefile
@@ -28,6 +28,7 @@ CONFIG = package/config
noconfig_targets := menuconfig config oldconfig randconfig \
defconfig allyesconfig allnoconfig release tags \
+ source-check
# $(shell find . -name *_defconfig |sed 's/.*\///')
@@ -156,6 +157,13 @@ $(TARGET_DIR):
source: $(TARGETS_SOURCE) $(HOST_SOURCE)
+.config.check: dependencies
+ $(SED) '/BR2_WGET/s/\"$$/ --spider\"/g' .config
+ touch $@
+
+_source-check: .config.check
+ $(MAKE) source
+
#############################################################
#
# Cleanup and misc junk
@@ -214,9 +222,9 @@ randconfig: $(CONFIG)/conf
@$(CONFIG)/conf -r $(CONFIG_CONFIG_IN)
allyesconfig: $(CONFIG)/conf
- #@$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
+ cp $(CONFIG_DEFCONFIG) .config
+ @$(CONFIG)/conf -y $(CONFIG_CONFIG_IN)
#sed -i -e "s/^CONFIG_DEBUG.*/# CONFIG_DEBUG is not set/" .config
- @$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
allnoconfig: $(CONFIG)/conf
@$(CONFIG)/conf -n $(CONFIG_CONFIG_IN)
@@ -228,6 +236,10 @@ defconfig: $(CONFIG)/conf
cp $(shell find . -name $@) .config
@$(CONFIG)/conf -o $(CONFIG_CONFIG_IN)
+# check if download URLs are outdated
+source-check: allyesconfig
+ $(MAKE) _source-check
+
#############################################################
#
# Cleanup and misc junk