summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2010-04-10 22:42:45 +0200
committerThomas Petazzoni2010-04-11 06:01:08 +0200
commit87b0637bd086ecdaf01f6f108bd68eb7662397ca (patch)
treed1e420b4e5ffddfe48bcbf1476c24f1ba2f271ff /Makefile
parentDo not let packages remove man pages, info pages and documentation (diff)
downloadbuildroot-87b0637bd086ecdaf01f6f108bd68eb7662397ca.tar.gz
buildroot-87b0637bd086ecdaf01f6f108bd68eb7662397ca.tar.xz
buildroot-87b0637bd086ecdaf01f6f108bd68eb7662397ca.zip
Remove all documentation when BR2_HAVE_DOCUMENTATION is not set
Until now, we had BR2_HAVE_MANPAGES, BR2_HAVE_INFOPAGES and BR2_HAVE_DOCUMENTATION, but there's no need to have such a fine-grained control over what documentation gets kept or not. Therefore, just remove all the documentation (man pages, info pages and documentation in $(TARGET_DIR)/usr/doc and $(TARGET_DIR)/usr/share/doc) when BR2_HAVE_DOCUMENTATION is not set. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index ce6bf3d4c..03ed4c505 100644
--- a/Makefile
+++ b/Makefile
@@ -409,11 +409,10 @@ else
find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
endif
-ifneq ($(BR2_HAVE_MANPAGES),y)
+ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/man
-endif
-ifneq ($(BR2_HAVE_INFOPAGES),y)
rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
+ rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
endif
find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
$(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null