summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2010-10-17 23:32:37 +0200
committerPeter Korsgaard2010-10-17 23:32:37 +0200
commit891973f53805e35a4a14657f2c922ee7c5ff7cf7 (patch)
tree7593f25ca0bf7419f8610a0cd524cc0dad650ddf /Makefile
parentstartup-notification: ensure cross-X11 headers/libs are used (diff)
downloadbuildroot-891973f53805e35a4a14657f2c922ee7c5ff7cf7.tar.gz
buildroot-891973f53805e35a4a14657f2c922ee7c5ff7cf7.tar.xz
buildroot-891973f53805e35a4a14657f2c922ee7c5ff7cf7.zip
Makefile: move KERNEL_ARCH from kernel-headers to here
Closes #2707 It's not only for kernel headers, and the kernel headers .mk file isn't included for crosstool-ng toolchain, which broke linux/u-boot/.. builds. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index ac60b24ee..22c3801d1 100644
--- a/Makefile
+++ b/Makefile
@@ -249,6 +249,14 @@ ifeq ($(ARCH),xtensa)
ARCH:=$(ARCH)_$(call qstrip,$(BR2_xtensa_core_name))
endif
+KERNEL_ARCH:=$(shell echo "$(ARCH)" | sed -e "s/-.*//" \
+ -e s/i.86/i386/ -e s/sun4u/sparc64/ \
+ -e s/arm.*/arm/ -e s/sa110/arm/ \
+ -e s/parisc64/parisc/ \
+ -e s/powerpc64/powerpc/ \
+ -e s/ppc.*/powerpc/ -e s/mips.*/mips/ \
+ -e s/sh.*/sh/)
+
ZCAT:=$(call qstrip,$(BR2_ZCAT))
BZCAT:=$(call qstrip,$(BR2_BZCAT))
TAR_OPTIONS=$(call qstrip,$(BR2_TAR_OPTIONS)) -xf