summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2008-11-07 09:57:59 +0100
committerPeter Korsgaard2008-11-07 09:57:59 +0100
commit95e165c2bc68a92e2d16c12582d00bc01b349813 (patch)
tree8d15b5a722e8b029ac36082db5f87ccafe5431e4 /Makefile
parentMakefile.autotools.in: make MESSAGE output stand out (diff)
downloadbuildroot-95e165c2bc68a92e2d16c12582d00bc01b349813.tar.gz
buildroot-95e165c2bc68a92e2d16c12582d00bc01b349813.tar.xz
buildroot-95e165c2bc68a92e2d16c12582d00bc01b349813.zip
Makefile: revert HOST_GLIB_BIN staging_dir fix (r23920,23923)
It causes more trouble than it's worth, and we should move to building those host tools ourselves to not get into version issues anyway.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 0b27ed1fc..bd3c7c92e 100644
--- a/Makefile
+++ b/Makefile
@@ -122,8 +122,7 @@ HOSTCPP:=$(shell $(CONFIG_SHELL) -c "which $(HOSTCPP)" || type -p $(HOSTCPP) ||
HOSTLD:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLD)" || type -p $(HOSTLD) || echo ld)
HOSTLN:=$(shell $(CONFIG_SHELL) -c "which $(HOSTLN)" || type -p $(HOSTLN) || echo ln)
HOSTNM:=$(shell $(CONFIG_SHELL) -c "which $(HOSTNM)" || type -p $(HOSTNM) || echo nm)
-# ignore version in staging_dir
-HOST_GLIB_BIN:=`dirname $(shell $(CONFIG_SHELL) -c "(which -a glib-genmarshal; echo /usr/bin/glib-genmarshal)|grep -v $(BR2_STAGING_DIR)|head -n 1")`
+HOST_GLIB_BIN:=`dirname $(shell $(CONFIG_SHELL) -c "which glib-genmarshal" || echo /usr/bin/glib-genmarshal)`
HOST_GLIB:=$(shell $(CONFIG_SHELL) -c "dirname $(HOST_GLIB_BIN)" || echo /usr)