summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen2002-12-11 00:26:31 +0100
committerEric Andersen2002-12-11 00:26:31 +0100
commit98b6fb27b3fa0960a94e4545b0b7c4498b1dc8e6 (patch)
tree97a40c10cb9b5bc8e36dc27310bcbe2416d1ca38 /Makefile
parentUpdate the default config (diff)
downloadbuildroot-98b6fb27b3fa0960a94e4545b0b7c4498b1dc8e6.tar.gz
buildroot-98b6fb27b3fa0960a94e4545b0b7c4498b1dc8e6.tar.xz
buildroot-98b6fb27b3fa0960a94e4545b0b7c4498b1dc8e6.zip
Support building regular kernels
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 45eb98519..05be5e86e 100644
--- a/Makefile
+++ b/Makefile
@@ -61,6 +61,11 @@ ifeq ($(USE_UCLIBC_TOOLCHAIN),true)
TARGETS=uclibc_toolchain
endif
+# Do you want user mode Linux, or are you building a
+# real kernel that will run on its own?
+TARGETS+=linux
+#TARGETS+=user-mode-linux
+
# The default minimal set
TARGETS+=user-mode-linux busybox tinylogin
@@ -87,7 +92,6 @@ TARGETS+=ext2root
#############################################################
BASE_DIR:=${shell pwd}
HOSTCC:=gcc
-LINUX_KERNEL=$(BASE_DIR)/UMlinux
SOURCE_DIR:=$(BASE_DIR)/sources
DL_DIR:=$(SOURCE_DIR)/dl
PATCH_DIR=$(SOURCE_DIR)/patches