summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorUlf Samuelsson2008-03-28 08:31:28 +0100
committerUlf Samuelsson2008-03-28 08:31:28 +0100
commita1b0651a5a43a21355683f7e3461f654d9334f23 (patch)
tree07e4d626a4cc9aefa40e484b006bf75b91ca8341 /Makefile
parentAdded udpcast package. (diff)
downloadbuildroot-a1b0651a5a43a21355683f7e3461f654d9334f23.tar.gz
buildroot-a1b0651a5a43a21355683f7e3461f654d9334f23.tar.xz
buildroot-a1b0651a5a43a21355683f7e3461f654d9334f23.zip
Use BUSYBOX_LOCAL shell variable, if defined
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/Makefile b/Makefile
index 9f9f0628d..5a74f8a1f 100644
--- a/Makefile
+++ b/Makefile
@@ -31,23 +31,28 @@ noconfig_targets:=menuconfig config oldconfig randconfig \
defconfig allyesconfig allnoconfig release tags \
source-check help
-# $(shell find . -name *_defconfig |sed 's/.*\///')
-# Pull in the user's configuration file
-ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
-ifeq ($(BOARD),)
--include $(TOPDIR).config
-else
--include $(TOPDIR)/local/$(BOARD)/$(BOARD).config
-endif
-endif
+# Use shell variables, if defined
ifneq ($(BUILDROOT_DL_DIR),)
BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
endif
+
ifneq ($(BUILDROOT_LOCAL),)
LOCAL:=$(BUILDROOT_LOCAL)
else
-LOCAL:=local
+LOCAL:=$(TOPDIR)/local
+endif
+
+# $(shell find . -name *_defconfig |sed 's/.*\///')
+# Pull in the user's configuration file
+ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
+ifeq ($(BOARD),)
+# if "make BOARD=xyz" command
+-include $(TOPDIR).config
+else
+# if "make" command
+-include $(LOCAL)/$(BOARD)/$(BOARD).config
+endif
endif
# To put more focus on warnings, be less verbose as default