summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2011-01-11 21:44:29 +0100
committerThomas Petazzoni2011-01-25 08:59:57 +0100
commitb0c86bcc57b1bd714dc0d1cc719ffdfd6f0663dd (patch)
treee7117ba65e6f0cdfcfa458d6e89ca9b2528c2a9d /Makefile
parentpython: convert to autotargets, bump to 2.7.1, many improvements (diff)
downloadbuildroot-b0c86bcc57b1bd714dc0d1cc719ffdfd6f0663dd.tar.gz
buildroot-b0c86bcc57b1bd714dc0d1cc719ffdfd6f0663dd.tar.xz
buildroot-b0c86bcc57b1bd714dc0d1cc719ffdfd6f0663dd.zip
Remove .py or .pyc depending on Python configuration
We do this at a global level since several packages can install Python modules. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index cf2a7dcf6..a5a37a1ee 100644
--- a/Makefile
+++ b/Makefile
@@ -438,6 +438,12 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/share/gtk-doc
-rmdir $(TARGET_DIR)/usr/share 2>/dev/null
endif
+ifeq ($(BR2_PACKAGE_PYTHON_PY_ONLY),y)
+ find $(TARGET_DIR)/usr/lib/ -name '*.pyc' -print0 | xargs -0 rm -f
+endif
+ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
+ find $(TARGET_DIR)/usr/lib/ -name '*.py' -print0 | xargs -0 rm -f
+endif
find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db*.so*' | \
xargs $(STRIPCMD) 2>/dev/null || true
find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \