summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard2009-12-12 00:16:33 +0100
committerPeter Korsgaard2009-12-12 00:16:33 +0100
commitb5972138c3e6912b29578e12cbe4689a2481abcf (patch)
tree9fc08c445864906b5392ca884ff43abc4097c9c0 /Makefile
parentgcc: native toolchain needs BR2_HAVE_DEVFILES (diff)
downloadbuildroot-b5972138c3e6912b29578e12cbe4689a2481abcf.tar.gz
buildroot-b5972138c3e6912b29578e12cbe4689a2481abcf.tar.xz
buildroot-b5972138c3e6912b29578e12cbe4689a2481abcf.zip
Makefile: drop config cache on .config changes
The config cache might contain invalid values when .config is changed (E.G. when adding/removing libraries), so drop it so config checks are rerun for new packages (existing package still won't be rebuilt). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 904121e2e..f8303e137 100644
--- a/Makefile
+++ b/Makefile
@@ -440,6 +440,14 @@ external-deps:
@$(MAKE) -Bs BR2_WGET=$(TOPDIR)/toolchain/wget-show-external-deps.sh \
SPIDER=--spider source
+ifeq ($(BR2_CONFIG_CACHE),y)
+$(BUILD_DIR)/tgt-config.cache: .config
+ rm -f $@
+ touch $@
+
+$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache
+endif
+
else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
all: menuconfig