diff options
author | Thomas Petazzoni | 2012-04-17 16:45:22 +0200 |
---|---|---|
committer | Peter Korsgaard | 2012-04-20 00:00:29 +0200 |
commit | b7285d0058978fb88a94985dba150e849e4d9a69 (patch) | |
tree | fdecfeeca6fe1cbba67643a14600b9d71784fcca /Makefile | |
parent | openssl: security bump to version 1.0.0i (diff) | |
download | buildroot-b7285d0058978fb88a94985dba150e849e4d9a69.tar.gz buildroot-b7285d0058978fb88a94985dba150e849e4d9a69.tar.xz buildroot-b7285d0058978fb88a94985dba150e849e4d9a69.zip |
Move the manual build infrastructure to docs/manual/manual.mk
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 49 |
1 files changed, 1 insertions, 48 deletions
@@ -685,54 +685,7 @@ release: print-version: @echo $(BR2_VERSION_FULL) -################################################################################ -# GENDOC -- generates the make targets needed to build a specific type of -# asciidoc documentation. -# -# argument 1 is the name of the document and must be a subdirectory of docs/; -# the top-level asciidoc file must have the same name -# argument 2 is the type of document to generate (-f argument of a2x) -# argument 3 is the document type as used in the make target -# argument 4 is the output file extension for the document type -# argument 5 is the human text for the document type -# argument 6 (optional) are extra arguments for a2x -# -# The variable <DOCUMENT_NAME>_SOURCES defines the dependencies. -################################################################################ -define GENDOC_INNER -$(1): $(1)-$(3) -.PHONY: $(1)-$(3) -$(1)-$(3): $$(O)/docs/$(1)/$(1).$(4) - -$$(O)/docs/$(1)/$(1).$(4): docs/$(1)/$(1).txt $$($(call UPPERCASE,$(1))_SOURCES) - @echo "Generating $(5) $(1)..." - $(Q)mkdir -p $$(@D) - $(Q)a2x $(6) -f $(2) -d book -L -r $(TOPDIR)/docs/images \ - -D $$(@D) $$< -endef - -################################################################################ -# GENDOC -- generates the make targets needed to build asciidoc documentation. -# -# argument 1 is the name of the document and must be a subdirectory of docs/; -# the top-level asciidoc file must have the same name -# -# The variable <DOCUMENT_NAME>_SOURCES defines the dependencies. -################################################################################ -define GENDOC -$(call GENDOC_INNER,$(1),xhtml,html,html,HTML) -$(call GENDOC_INNER,$(1),chunked,split-html,chunked,Split HTML) -$(call GENDOC_INNER,$(1),pdf,pdf,pdf,PDF,--dblatex-opts "-P latex.output.revhistory=0") -$(call GENDOC_INNER,$(1),text,txt,text,Text) -$(call GENDOC_INNER,$(1),epub,epub,epub,EPUB) -clean: clean-$(1) -clean-$(1): - $(Q)$(RM) -rf $(O)/docs/$(1) -.PHONY: $(1) clean-$(1) -endef - -MANUAL_SOURCES = $(wildcard docs/manual/*.txt) $(wildcard docs/images/*) -$(eval $(call GENDOC,manual)) +include docs/manual/manual.mk .PHONY: $(noconfig_targets) |