summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorAnders Darander2009-12-23 10:05:45 +0100
committerPeter Korsgaard2009-12-23 11:54:25 +0100
commitb9656e81a460ddbfc8668b9902a4a6f8b2bc2521 (patch)
treefcc484ebceab49bc805ae79d7b3f52d88a9eb054 /Makefile
parentxfsprogs: bump version (diff)
downloadbuildroot-b9656e81a460ddbfc8668b9902a4a6f8b2bc2521.tar.gz
buildroot-b9656e81a460ddbfc8668b9902a4a6f8b2bc2521.tar.xz
buildroot-b9656e81a460ddbfc8668b9902a4a6f8b2bc2521.zip
Remove backup-files from the TARGET_DIR.
Closes #823. ~ is commonly used as a suffix to editor backup files. Remove these files, just as we remove CVS-directories and .empty-files. [Peter: tweaked to remove in same find invocation as .empty] Signed-off-by: Anders Darander <ad@datarespons.se> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 051b661fe..5f7114853 100644
--- a/Makefile
+++ b/Makefile
@@ -386,7 +386,7 @@ $(BUILD_DIR)/.root:
touch $(STAGING_DIR)/.fakeroot.00000; \
fi
-find $(TARGET_DIR) -type d -name CVS -print0 -o -name .svn -print0 | xargs -0 rm -rf
- -find $(TARGET_DIR) -type f -name .empty -print0 | xargs -0 rm -rf
+ -find $(TARGET_DIR) -type f \( -name .empty -o -name '*~' \) -print0 | xargs -0 rm -rf
touch $@
$(TARGET_DIR): $(BUILD_DIR)/.root