summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDanomi Mocelopolis2011-07-17 22:17:08 +0200
committerPeter Korsgaard2011-07-17 22:19:19 +0200
commitb979619973dad84c2ef6a978b3a3b04b35d6ce3a (patch)
tree7fef41f2a6cab25905ba3be10a937eeb4d596de7 /Makefile
parenttoolchain/crosstool-NG: use the package infrastructure (diff)
downloadbuildroot-b979619973dad84c2ef6a978b3a3b04b35d6ce3a.tar.gz
buildroot-b979619973dad84c2ef6a978b3a3b04b35d6ce3a.tar.xz
buildroot-b979619973dad84c2ef6a978b3a3b04b35d6ce3a.zip
make help: sort defconfigs for make 3.82
Closes #3985 The wildcard function in make 3.82 no longer sorts the output, so add an explicit sort so the defconfigs are listed in a sensible order. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index ffe634391..02a165999 100644
--- a/Makefile
+++ b/Makefile
@@ -668,7 +668,7 @@ endif
@echo ' make V=0|1 - 0 => quiet build (default), 1 => verbose build'
@echo ' make O=dir - Locate all output files in "dir", including .config'
@echo
- @$(foreach b, $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig)), \
+ @$(foreach b, $(sort $(notdir $(wildcard $(TOPDIR)/configs/*_defconfig))), \
printf " %-35s - Build for %s\\n" $(b) $(b:_defconfig=);)
@echo
@echo 'See docs/README and docs/buildroot.html for further details'