summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen2006-11-15 07:52:00 +0100
committerEric Andersen2006-11-15 07:52:00 +0100
commitba70f94e629ece312a4bf2b9b663a4f73d6032bb (patch)
tree4a165103220461604c47652f62a373f679728577 /Makefile
parentbring up to version 3.31 (diff)
downloadbuildroot-ba70f94e629ece312a4bf2b9b663a4f73d6032bb.tar.gz
buildroot-ba70f94e629ece312a4bf2b9b663a4f73d6032bb.tar.xz
buildroot-ba70f94e629ece312a4bf2b9b663a4f73d6032bb.zip
subversion makes it so we do not need a separate tarball
to store empty directories and symlinks for the target_skeleton.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 49b0168a4..eefa9e582 100644
--- a/Makefile
+++ b/Makefile
@@ -103,11 +103,8 @@ $(STAGING_DIR):
@ln -snf ../lib $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib
$(TARGET_DIR):
- if [ -f "$(TARGET_SKELETON)" ] ; then \
- $(ZCAT) $(TARGET_SKELETON) | tar -C $(BUILD_DIR) -xf -; \
- fi;
- if [ -d "$(TARGET_SKEL_DIR)" ] ; then \
- cp -fa $(TARGET_SKEL_DIR)/* $(TARGET_DIR)/; \
+ if [ -d "$(TARGET_SKELETON)" ] ; then \
+ cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
fi;
touch $(STAGING_DIR)/.fakeroot.00000
-find $(TARGET_DIR) -type d -name CVS | xargs rm -rf