summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2009-12-14 12:10:12 +0100
committerThomas Petazzoni2009-12-14 23:54:47 +0100
commitbc994c533cdac1ab843a889c4afaae80234cc6b2 (patch)
tree1802f44de52ea1bf9614843b1115dcd6bbab7ab6 /Makefile
parentuclibc: remove support for external source toolchains (diff)
downloadbuildroot-bc994c533cdac1ab843a889c4afaae80234cc6b2.tar.gz
buildroot-bc994c533cdac1ab843a889c4afaae80234cc6b2.tar.xz
buildroot-bc994c533cdac1ab843a889c4afaae80234cc6b2.zip
Use BR2_TOOLCHAIN_BUILDROOT instead of BR2_TOOLCHAIN_SOURCE
The BR2_TOOLCHAIN_SOURCE option is removed in a future commit. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 5b71051c1..051b661fe 100644
--- a/Makefile
+++ b/Makefile
@@ -197,7 +197,7 @@ PREFERRED_LIB_FLAGS:=--enable-static --enable-shared
# along with the packages to build for the target.
#
##############################################################
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
BASE_TARGETS:=uclibc-configured binutils cross_compiler uclibc-target-utils kernel-headers
else
BASE_TARGETS:=uclibc
@@ -289,7 +289,7 @@ include .config.cmd
# We also need the various per-package makefiles, which also add
# each selected package to TARGETS if that package was selected
# in the .config file.
-ifeq ($(BR2_TOOLCHAIN_SOURCE),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
# avoid pulling in external toolchain which is broken for toplvl parallel builds
# Explicit ordering:
include toolchain/dependencies/dependencies.mk