summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMalte Starostik2010-07-24 13:21:25 +0200
committerPeter Korsgaard2010-07-30 10:45:00 +0200
commitbea9e43fe7d0adbcd472fb8b5f56aba5e2004f80 (patch)
tree4adc93823fd5b305121ddbb801060512eb4d6c9b /Makefile
parentPurge libglib2 dev files from target (diff)
downloadbuildroot-bea9e43fe7d0adbcd472fb8b5f56aba5e2004f80.tar.gz
buildroot-bea9e43fe7d0adbcd472fb8b5f56aba5e2004f80.tar.xz
buildroot-bea9e43fe7d0adbcd472fb8b5f56aba5e2004f80.zip
Globally remove aclocal directories from target
* Remove $(TARGET_DIR)/usr/share/aclocal from target-finalize when not installing devfiles and * Remove some (now) redundant cleanup from individual packages Signed-off-by: Malte Starostik <m-starostik@versanet.de> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 619d8ea03..f130325a4 100644
--- a/Makefile
+++ b/Makefile
@@ -384,7 +384,7 @@ target-finalize:
ifeq ($(BR2_HAVE_DEVFILES),y)
( scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
else
- rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig
+ rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/aclocal
find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
endif