summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorManuel Novoa III2004-09-14 13:52:26 +0200
committerManuel Novoa III2004-09-14 13:52:26 +0200
commitbfa9ce0e4c5a8c823f94f32bb0e097f4bab10597 (patch)
treeca7b68caf55ce583719d5e49a7eb66f7ad04eb19 /Makefile
parentAesthetic change... Current gcc cvs removes the unnecessary dependency ref (diff)
downloadbuildroot-bfa9ce0e4c5a8c823f94f32bb0e097f4bab10597.tar.gz
buildroot-bfa9ce0e4c5a8c823f94f32bb0e097f4bab10597.tar.xz
buildroot-bfa9ce0e4c5a8c823f94f32bb0e097f4bab10597.zip
Add back in support for 3.3.4 soft float toolchains, although arm would
require reenabling linking with -lfloat in uClibc.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 04465a40c..ac6df4c4f 100644
--- a/Makefile
+++ b/Makefile
@@ -129,16 +129,17 @@ GCC_WITH_TUNE:=
# Soft floating point options.
# Notes:
-# Currently builds with gcc 3.3 for arm, mips, mipsel, powerpc.
+# Builds for gcc 3.4.x.
+# Can build for gcc 3.3.x for mips, mipsel, powerpc, and arm (special)
+# by using custom specs files (currently for 3.3.4 only).
+# NOTE!!! The libfloat stuff is currently removed from uClibc. The
+# arm soft float for 3.3.x will require reenabling it.
# (i386 support will be added back in at some point.)
# Only tested with multilib enabled.
# For i386, long double is the same as double (64 bits). While this
# is unusual for x86, it seemed the best approach considering the
# limitations in the gcc floating point emulation library.
# For arm, soft float uses the usual libfloat routines.
-# Custom specs files are used to set the default gcc mode to soft float
-# as a convenience, since you shouldn't link hard and soft float
-# together. In fact, arm won't even let you.
# (Un)comment the appropriate line below.
#SOFT_FLOAT:=true
SOFT_FLOAT:=false