summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-06-02 13:22:17 +0200
committerBernhard Reutner-Fischer2007-06-02 13:22:17 +0200
commitc6e43c9da3b6aa7581352a20c6478436ab17dd6d (patch)
tree98b6ca3ef566de53fc7f7c993fd8985628fb56b1 /Makefile
parent- move setting up the extensions to correct place (like i said but tom didn't... (diff)
downloadbuildroot-c6e43c9da3b6aa7581352a20c6478436ab17dd6d.tar.gz
buildroot-c6e43c9da3b6aa7581352a20c6478436ab17dd6d.tar.xz
buildroot-c6e43c9da3b6aa7581352a20c6478436ab17dd6d.zip
- fixup the extension for the host and start to honor BR2_PREFER_STATIC_LIB
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index d80956319..dff5fbf8e 100644
--- a/Makefile
+++ b/Makefile
@@ -48,38 +48,38 @@ cc-option = $(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /d
#############################################################
#
-# Setup the proper filename extensions for the target
+# Setup the proper filename extensions for the host
#
##############################################################
ifneq ($(findstring linux,$(BR2_GNU_BUILD_SUFFIX)),)
-EXEEXT:=
-LIBEXT:=.a
-SHREXT:=.so
+HOST_EXEEXT:=
+HOST_LIBEXT:=.a
+HOST_SHREXT:=.so
endif
ifneq ($(findstring apple,$(BR2_GNU_BUILD_SUFFIX)),)
-EXEEXT:=
-LIBEXT:=.a
-SHREXT:=.dylib
+HOST_EXEEXT:=
+HOST_LIBEXT:=.a
+HOST_SHREXT:=.dylib
endif
ifneq ($(findstring cygwin,$(BR2_GNU_BUILD_SUFFIX)),)
-EXEEXT:=.exe
-LIBEXT:=.lib
-SHREXT:=.dll
+HOST_EXEEXT:=.exe
+HOST_LIBEXT:=.lib
+HOST_SHREXT:=.dll
endif
ifneq ($(findstring mingw,$(BR2_GNU_BUILD_SUFFIX)),)
-EXEEXT:=.exe
-LIBEXT:=.lib
-SHREXT:=.dll
+HOST_EXEEXT:=.exe
+HOST_LIBEXT:=.lib
+HOST_SHREXT:=.dll
endif
+# The preferred type of libs we build for the target
ifeq ($(BR2_PREFER_STATIC_LIB),y)
-LIBTGTEXT=$(LIBEXT)
+LIBTGTEXT=.a
else
-LIBTGTEXT=$(SHREXT)
+LIBTGTEXT=.so
endif
-
#############################################################
#
# The list of stuff to build for the target toolchain