summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2011-04-02 18:44:36 +0200
committerPeter Korsgaard2011-04-02 22:34:09 +0200
commitc729829c6c3f7c5bccf2a4370f8df853642b23b8 (patch)
treefb0a29a66dbe39e4b95e891fde066e9f5a2f5808 /Makefile
parentlighttpd: fix build without webdav support (diff)
downloadbuildroot-c729829c6c3f7c5bccf2a4370f8df853642b23b8.tar.gz
buildroot-c729829c6c3f7c5bccf2a4370f8df853642b23b8.tar.xz
buildroot-c729829c6c3f7c5bccf2a4370f8df853642b23b8.zip
Fix ccache handling
When ccache support is enabled and 'make silentoldconfig' is being started from the following rule: $(BUILD_DIR)/buildroot-config/auto.conf: $(CONFIG_DIR)/.config $(MAKE) $(EXTRAMAKEARGS) HOSTCC="$(HOSTCC_NOCCACHE)" HOSTCXX="$(HOSTCXX_NOCCACHE)" silentoldconfig then, the Makefile in package/config inherits from HOSTCC/HOSTCXX values with the ccache prefix. However, if we start from a cleaned build (after make clean), ccache is not compiled yet, so things break. To solve this, we pass a noccache variant of HOSTCC/HOSTCXX down to the package/config Makefile. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 9aa7399f1..2e698cc18 100644
--- a/Makefile
+++ b/Makefile
@@ -367,7 +367,7 @@ dirs: $(DL_DIR) $(TOOLCHAIN_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) \
$(BASE_TARGETS): dirs $(O)/toolchainfile.cmake
$(BUILD_DIR)/buildroot-config/auto.conf: $(CONFIG_DIR)/.config
- $(MAKE) $(EXTRAMAKEARGS) silentoldconfig
+ $(MAKE) $(EXTRAMAKEARGS) HOSTCC="$(HOSTCC_NOCCACHE)" HOSTCXX="$(HOSTCXX_NOCCACHE)" silentoldconfig
prepare: $(BUILD_DIR)/buildroot-config/auto.conf