summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMike Frysinger2010-11-20 11:29:28 +0100
committerPeter Korsgaard2010-11-24 22:24:06 +0100
commitc98bc88e3296222a20e59cfb7b9f3ec5aee3be1c (patch)
tree62937e32cd65bda535d9f79ebf571972f4533382 /Makefile
parentauto remove empty /usr/share dir (diff)
downloadbuildroot-c98bc88e3296222a20e59cfb7b9f3ec5aee3be1c.tar.gz
buildroot-c98bc88e3296222a20e59cfb7b9f3ec5aee3be1c.tar.xz
buildroot-c98bc88e3296222a20e59cfb7b9f3ec5aee3be1c.zip
target-finalize: do not strip libthread_db.so
For proper threading debug support, the libthread_db.so library cannot be stripped on the target. This is because the target gdbserver will also load up this library at runtime and poke around its symbols. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 86aea91a2..22ae1d060 100644
--- a/Makefile
+++ b/Makefile
@@ -418,7 +418,8 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/share/gtk-doc
-rmdir $(TARGET_DIR)/usr/share 2>/dev/null
endif
- find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
+ find $(TARGET_DIR) -type f -perm +111 '!' -name 'libthread_db.so*' | \
+ xargs $(STRIPCMD) 2>/dev/null || true
find $(TARGET_DIR)/lib/modules -type f -name '*.ko' | \
xargs -r $(STRIPCMD) $(STRIP_STRIP_UNNEEDED)