summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorManuel Novoa III2004-09-10 20:58:11 +0200
committerManuel Novoa III2004-09-10 20:58:11 +0200
commitce1dd7b540443b9b487d082ae34989a8b5a2c032 (patch)
treec464c1c490b61cd68e41e099cdbbe89f4afd24d8 /Makefile
parentPeter noticed some bits were missing. (diff)
downloadbuildroot-ce1dd7b540443b9b487d082ae34989a8b5a2c032.tar.gz
buildroot-ce1dd7b540443b9b487d082ae34989a8b5a2c032.tar.xz
buildroot-ce1dd7b540443b9b487d082ae34989a8b5a2c032.zip
Integrate gcc 3.4.2 and add patches from both openembedded (6??-*)
and Dan Kegel's crosstools (7??-*). Use makefile vars for toolchain names in ccache.mk and gdb.mk. Fix a g++-related symlink issue with ccache. Change the default to gcc 3.4.2 and binutils 2.15.91.0.2 (now that mips is building). Let the users go forth and test... ;-)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 740cf07a6..04465a40c 100644
--- a/Makefile
+++ b/Makefile
@@ -50,6 +50,7 @@ ARCH:=i386
#
DEFAULT_KERNEL_HEADERS:=2.4.25
#DEFAULT_KERNEL_HEADERS:=2.6.7
+#DEFAULT_KERNEL_HEADERS:=2.6.8
# Choose gcc version.
# WARNING -- 2.95 currently only builds for i386, arm, mips*, and powerpc.
@@ -59,7 +60,8 @@ DEFAULT_KERNEL_HEADERS:=2.4.25
#GCC_VERSION:=3.3.3
#GCC_VERSION:=3.3.4
#GCC_VERSION:=3.4.0
-GCC_VERSION:=3.4.1
+#GCC_VERSION:=3.4.1
+GCC_VERSION:=3.4.2
# Choose binutils version.
#
@@ -70,9 +72,9 @@ GCC_VERSION:=3.4.1
#BINUTILS_VERSION:=2.15.90.0.1
#BINUTILS_VERSION:=2.15.90.0.1.1
#BINUTILS_VERSION:=2.15.90.0.2
-BINUTILS_VERSION:=2.15.90.0.3
+#BINUTILS_VERSION:=2.15.90.0.3
#BINUTILS_VERSION:=2.15.91.0.1
-#BINUTILS_VERSION:=2.15.91.0.2
+BINUTILS_VERSION:=2.15.91.0.2
# Choose gdb version.
#
@@ -212,8 +214,11 @@ TARGETS+=busybox #tinylogin
# More development system stuff for those that want it
#TARGETS+=m4 autoconf automake libtool
-# Some nice debugging tools
-#TARGETS+=gdb strace ltrace
+# Some nice debugging tools for the host
+#TARGETS+=gdbclient
+# Some nice debugging tools for the target
+#TARGETS+=gdbserver gdb_target
+#TARGETS+=strace ltrace
# The Valgrind debugger (x86 only)
#TARGETS+=valgrind