summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen2005-02-10 04:06:39 +0100
committerEric Andersen2005-02-10 04:06:39 +0100
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /Makefile
parentmenuconfig -> config (diff)
downloadbuildroot-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.xz
buildroot-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 3b263de31..e6eb5cca9 100644
--- a/Makefile
+++ b/Makefile
@@ -51,11 +51,8 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
##############################################################
TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils
include toolchain/Makefile.in
-include toolchain/*/Makefile.in
include package/Makefile.in
-include package/*/Makefile.in
include target/Makefile.in
-include target/*/Makefile.in
#############################################################
#
@@ -71,6 +68,13 @@ all: world
# In this section, we need .config
include .config.cmd
+# We also need the various per-package makefiles, which also add
+# each selected package to TARGETS if that package was selected
+# in the .config file.
+include toolchain/*/*.mk
+include package/*/*.mk
+include target/*/*.mk
+
TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
@@ -81,10 +85,6 @@ world: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS)
$(TARGETS_CLEAN) $(TARGETS_DIRCLEAN) $(TARGETS_SOURCE) \
$(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR) $(STAGING_DIR)
-include toolchain/*/*.mk
-include package/*/*.mk
-include target/*/*.mk
-
#############################################################
#
# staging and target directories do NOT list these as