summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorEric Andersen2003-02-12 10:10:22 +0100
committerEric Andersen2003-02-12 10:10:22 +0100
commitd108fa86c933dbf2d33bd622a017b134fc524c27 (patch)
tree5a793b03693be0cc7c0395291e16676049d6ad0d /Makefile
parentLots and lots of changes (diff)
downloadbuildroot-d108fa86c933dbf2d33bd622a017b134fc524c27.tar.gz
buildroot-d108fa86c933dbf2d33bd622a017b134fc524c27.tar.xz
buildroot-d108fa86c933dbf2d33bd622a017b134fc524c27.zip
Fixup the target path
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 923b6c8cb..643b5e19e 100644
--- a/Makefile
+++ b/Makefile
@@ -145,9 +145,10 @@ PATCH_DIR=$(SOURCE_DIR)/patches
BUILD_DIR:=$(BASE_DIR)/build
TARGET_DIR:=$(BUILD_DIR)/root
STAGING_DIR:=$(BUILD_DIR)/staging_dir
-TARGET_CROSS:=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
-TARGET_CC:=$(TARGET_CROSS)gcc
-TARGET_PATH:=$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:/bin:/sbin:/usr/bin:/usr/sbin
+TOOL_BUILD_DIR=$(BASE_DIR)/build
+TARGET_PATH=$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/bin:/bin:/sbin:/usr/bin:/usr/sbin
+TARGET_CROSS=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
+TARGET_CC=$(TARGET_CROSS)gcc
STRIP:=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
#STRIP:=/bin/true
IMAGE:=$(BASE_DIR)/root_fs