summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorMaxime Petazzoni2010-09-02 12:31:57 +0200
committerThomas Petazzoni2010-09-13 08:18:40 +0200
commitd147b81fda4419ea7307835d39cdb58b965882aa (patch)
tree8099e2a2c709852f16f8c59e9c9ae086adf4d251 /Makefile
parentUse the normal download method for libsvgtiny (diff)
downloadbuildroot-d147b81fda4419ea7307835d39cdb58b965882aa.tar.gz
buildroot-d147b81fda4419ea7307835d39cdb58b965882aa.tar.xz
buildroot-d147b81fda4419ea7307835d39cdb58b965882aa.zip
Re-implement the source-check and external-deps targets
The new DL_MODE variable dispatches between the various download implementations of each method (Git, Subversion, Wget) to deal with the normal download (default mode, 'DOWNLOAD'), the source-check ('SOURCE_CHECK') and to show the external dependencies for external-deps ('SHOW_EXTERNAL_DEPS'). For the latter, the legacy script wget-show-external-deps.sh is no longer required as $(WGET) isn't called directly anymore but always through the DOWNLOAD helper. Signed-off-by: Maxime Petazzoni <maxime.petazzoni@bulix.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index 778040308..faa802bb7 100644
--- a/Makefile
+++ b/Makefile
@@ -244,19 +244,10 @@ ifeq ($(ARCH),xtensa)
ARCH:=$(ARCH)_$(call qstrip,$(BR2_xtensa_core_name))
endif
-WGET:=$(call qstrip,$(BR2_WGET)) $(QUIET)
-SVN:=$(call qstrip,$(BR2_SVN)) $(QUIET)
-BZR:=$(call qstrip,$(BR2_BZR)) $(QUIET)
-GIT:=$(call qstrip,$(BR2_GIT)) $(QUIET)
ZCAT:=$(call qstrip,$(BR2_ZCAT))
BZCAT:=$(call qstrip,$(BR2_BZCAT))
TAR_OPTIONS=$(call qstrip,$(BR2_TAR_OPTIONS)) -xf
-DL_DIR=$(call qstrip,$(BR2_DL_DIR))
-ifeq ($(DL_DIR),)
-DL_DIR:=$(TOPDIR)/dl
-endif
-
GNU_TARGET_SUFFIX:=-$(call qstrip,$(BR2_GNU_TARGET_SUFFIX))
STAGING_DIR:=$(call qstrip,$(BR2_STAGING_DIR))
@@ -435,10 +426,10 @@ endif
source: $(TARGETS_SOURCE) $(HOST_SOURCE)
_source-check:
- @echo "TODO $@"
+ $(MAKE) DL_MODE=SOURCE_CHECK $(EXTRAMAKEARGS) source
external-deps:
- @echo "TODO $@"
+ @$(MAKE) -Bs DL_MODE=SHOW_EXTERNAL_DEPS $(EXTRAMAKEARGS) source
show-targets:
@echo $(TARGETS)