summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPaulius Zaleckas2010-05-05 12:09:36 +0200
committerPeter Korsgaard2010-05-05 12:21:21 +0200
commitd701a82321ad2f3e5bfa16639e93532294cad4ce (patch)
treef1f13ea0c3a739e0d4eb88870bb8628a17f91289 /Makefile
parenthal: cleanup package (diff)
downloadbuildroot-d701a82321ad2f3e5bfa16639e93532294cad4ce.tar.gz
buildroot-d701a82321ad2f3e5bfa16639e93532294cad4ce.tar.xz
buildroot-d701a82321ad2f3e5bfa16639e93532294cad4ce.zip
Remove gtk-doc documentations from target
On my target rootfs it is installed documentation for: atk, cairo, gdk, gdk-pixbuf, gio, glib, gobject, gtk, pango It ocupies 34M of space. Configure option --disable-gtk-doc doesn't prevent installation of it. So we should remove them manually if documentation is disabled. [Peter: also remove manual rm's from hal/libxml2/libglade] Signed-off-by: Paulius Zaleckas <paulius.zaleckas@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 607ec6d80..5da21d888 100644
--- a/Makefile
+++ b/Makefile
@@ -410,6 +410,7 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
rm -rf $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/man
rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
+ rm -rf $(TARGET_DIR)/usr/share/gtk-doc
endif
find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
$(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null