summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorThomas Petazzoni2010-08-21 18:50:44 +0200
committerThomas Petazzoni2010-09-01 12:27:25 +0200
commite1b1a18ab63ae3ef4eeb7f7cb4406a9cfbb12035 (patch)
treea30c387132ce7db3742b9c62864d5b4346d2561f /Makefile
parentFactorize environment variables for config utilities (diff)
downloadbuildroot-e1b1a18ab63ae3ef4eeb7f7cb4406a9cfbb12035.tar.gz
buildroot-e1b1a18ab63ae3ef4eeb7f7cb4406a9cfbb12035.tar.xz
buildroot-e1b1a18ab63ae3ef4eeb7f7cb4406a9cfbb12035.zip
Add support for savedefconfig
savedefconfig allows to create a minimal defconfig file from an existing configuration. For example : make O=/path/to/some/buildroot/build/directory savedefconfig will generate a minimal 'defconfig' file in the main Buildroot source directory. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index abe1aa02e..c897db76c 100644
--- a/Makefile
+++ b/Makefile
@@ -29,7 +29,7 @@ CONFIG=package/config
DATE:=$(shell date +%Y%m%d)
noconfig_targets:=menuconfig nconfig gconfig xconfig config oldconfig randconfig \
- defconfig %_defconfig allyesconfig allnoconfig release \
+ defconfig %_defconfig savedefconfig allyesconfig allnoconfig release \
randpackageconfig allyespackageconfig allnopackageconfig \
source-check help
@@ -547,6 +547,10 @@ defconfig: $(BUILD_DIR)/buildroot-config/conf
@mkdir -p $(BUILD_DIR)/buildroot-config
@$(COMMON_CONFIG_ENV) $< --defconfig=$(TOPDIR)/configs/$@ $(CONFIG_CONFIG_IN)
+savedefconfig: $(BUILD_DIR)/buildroot-config/conf
+ @mkdir -p $(BUILD_DIR)/buildroot-config
+ @$(COMMON_CONFIG_ENV) $< --savedefconfig=$(TOPDIR)/defconfig $(CONFIG_CONFIG_IN)
+
# check if download URLs are outdated
source-check: allyesconfig
$(MAKE) $(EXTRAMAKEARGS) _source-check